All Versions
12
Latest Version
Avg Release Cycle
77 days
Latest Release
66 days ago

Changelog History
Page 1

  • v5.1.0

    September 15, 2019

    🚀 This release adds support for Swift 5.1, iOS 13, and Xcode 11. Full updates here: #34

  • v5.0.1

    August 08, 2019

    📦 I fixed the Package.swift so that it is now compatible with Xcode 11 and the latest Swift Package Manifest file (// swift-tools-version:4.0).

  • v5.0.0

    May 25, 2019

    The master branch now uses Swift 5.0.

    There were no major changes with source compatibility.

  • v4.1.0

    September 17, 2018

    As of FontBlaster v4.1.0, , all future changes on master will be done in Xcode 10 using Swift 4.2.

    For those using Swift v4.1.0, please check out the swift4.1 branch or version 4.0.4 - both point to the same commit hash.

  • v4.0.4

    March 15, 2018
    • ⚡️ Updated Podspec file.
    • ✂ Removed .swift-version file, as it's been deprecated.
  • v4.0.3

    February 28, 2018

    🛠 Fixes a podspec issue that was introduced in 4.0.2.

  • v4.0.2

    February 28, 2018

    👍 Fontblaster supported tvOS out of the box. The podspec now explicitly supports allows for installation of Fontblaster on apps that target tvOS 9+.

  • v4.0.1

    November 10, 2017
    • #24
      • Removed deprecated code references to Character API as String and Character API changed in Swift 4 and is enforced in in Xcode 9.1 / iOS 11.1. (thanks to @andreyrd)
  • v4.0.0

    September 13, 2017

    👍 FontBlaster v4.0.0 adds support for Swift 4 / iOS 11 / Xcode 9. Only minor changes were made under-the-hood.

    👍 Moving forward, only support for the Swift 4 codebase (on master) will be maintained.

    ⚡️ | Swift Version | Branch Name | Will Continue to Receive Updates? | | --- | --- | --- | | 4.0 | master | Yes | | 3.2 | swift3.2 | No | | 3.1 | swift3.1 | No |

  • v3.0.4

    July 28, 2017
    • Minor Code Cleanup
    • Attempt at fixing #23