ReactiveTask v0.16.0 Release Notes

Release Date: 2019-06-13 // over 2 years ago
  • Breaking

    • โšก๏ธ Updated to ReactiveSwift 5 (#112). It requires Swift 4.2 or above. Thanks @mattprowse!

    โž• Added

    ๐Ÿ‘Œ Improved

    • Child processes should now terminate when the parent exits (#110). Thanks @ikesyo!

    ๐Ÿ›  Fixed

    Thank you to @mdiep and @ikesyo for reviewing pull requests.


Previous changes from v0.15.0

  • Breaking

    • โšก๏ธ Update ReactiveSwift to 4.0 (#107). So ReactiveTask now requires Xcode 9.4 (Swift 4.1). Thanks @ikesyo!

    ๐Ÿ‘Œ Improved

    • Utilize conditional conformances and synthesizing Equatable conformance (#108). Thanks @ikesyo!

    Thank you to @blender and @mdiep for reviewing pull requests.