Shallows v0.11.0 Release Notes

Release Date: 2019-11-15 // almost 2 years ago
  • Starting with 0.11.0, Swift Package Manager is the only officially supported dependency manager for Shallows. Main reason — maintaining Carthage and especially Cocoapods is not trivial, which can sometimes lead to a Podfile not being up-to-date, for example. You can use Cocoapods/Carthage and Swift PM hand in hand, so I hope the transition will not be too painful

    ⚡️ THIS UPDATE IS A BREAKING CHANGE
    ⚡️ Some APIs were slightly updated/removed. However, those are mostly non-primary APIs, and I expect that currently the very little amount of code depends on it. If you have problems migrating to 0.11.0, please, open an issue and I'll be glad to help!


Previous changes from v0.9.0

  • ⚡️ This update aims to simplify the API by removing techniques that haven't proven themselves worthy. It also focuses on making the codebase more readable and easier to understand, and also refines some names and implementation details.

    ⚡️ THIS UPDATE IS A BREAKING CHANGE
    🗄 Some API were deprecated, some - made unavailable. However, those are mostly non-primary APIs, and I expect that currently the very little amount of code depends on it. If you have problems migrating to 0.9.0, please, open an issue and I'll be glad to help!