ReactiveSwift v6.4.0 Release Notes

Release Date: 2020-09-29 // over 1 year ago
  • ๐Ÿš€ This is the forth minor release of ReactiveSwift 6.

    ๐Ÿ”„ Changes

    ๐Ÿš€ Minimum deployment target is now iOS 9.0+ when using Swift Package Manager, so as to silence Xcode 12 warnings. (#802)

    ๐Ÿ›  Fix a debug assertion in Lock.try() that could be raised in earlier OS versions (< iOS 10.0, < macOS 10.12). (#747, #788)

    Specifically, ReactiveSwift now recognizes EDEADLK as expected error code from pthread_mutex_trylock alongside 0, EBUSY and EAGAIN.